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System Requirements
The Graphic Speller for Macintosh requires MacOS 10.3.9 or later.  The Graphic Speller for 
Windows requires Windows XP or later.

A color monitor of 800 x 600 pixels or larger is required. The Graphic Speller resizes itself to fit 
your monitor, so the higher resolution you have, the sharper the picture will be.

Installation
Macintosh
To install The Graphic Speller on a Macintosh, insert the CD in the drive.  Double-click the 
installer icon to begin the process.  The installer places The Graphic Speller and the The Graphic 
Speller User’s Guide inside the Marblesoft folder in your Applications folder.  It will create a 
Marblesoft folder if none exists, and it will create an alias on your desktop. You can drag the 
alias to your Dock if you prefer.

Windows
To install The Graphic Speller on Windows, insert the CD in the drive.  The installer should start 
automatically.  If you have turned off the auto-start feature, double-click the SETUP.EXE icon to 
begin the process.  The installer places The Graphic Speller and the The Graphic Speller User’s 
Guide inside the Marblesoft folder in your Program Files folder.  It will create a Marblesoft 
folder if none exists, and it will add The Graphic Speller and the User’s Guide to your Start 
menu.

Running the Program
Macintosh
To launch The Graphic Speller, double-click the icon on your desktop, or click the icon in your 
Dock.  If you have deleted these aliases, or if you’re launching the program from a different user 
account, open your Applications folder, then the Marblesoft folder, then the The Graphic Speller 
folder.  Double click the The Graphic Speller icon to start the program.

Windows
To launch The Graphic Speller, select it from the Marblesoft folder in the Start menu.  If you 
have deleted this shortcut, open your Program Files folder, then the Marblesoft folder, then the 
The Graphic Speller folder.  Double click the The Graphic Speller icon to start the program.
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Menus
The program’s menu bar can be hidden or shown at any time. Press the “ESC” key to hide or 
show the menu bar. All the program settings and features can be controlled from the menu bar.  
You can also use keyboard shortcuts to access most menu items, even when the menu bar is 
hidden.

The Graphic Speller Menu (Mac only)
Use The Graphic Speller Menu to set preferences or to quit the program. 

File Menu (Windows only)
Use the File Menu to quit the program. 

Edit Menu
Use the Edit menu to copy and paste in a dialog.  On Windows, use the Edit menu to set 
preferences.

Options Menu
Use the Options menu to select the level of play or to set any of the activity options, input/
scanning options, or prompting and reinforcement options.  
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Playing the Game
The Graphic Speller uses words to teach simple graphing skills.  While the student does spell 
out words as the game proceeds, The Graphic Speller is really not a spelling program, it is a 
graphing program.

Level 1 	 Level 5

The program presents the student player with a number line (Level 1 above) or a graph (Level 5 
above), with optional letters placed on the graph.  

Note:  Levels 1 - 4 use number lines, and levels 5 - 9 use graphs.  In this manual, we’ll use the 
terms “graph” and “coordinates” to describe the activity, regardless of the level.

The student is prompted with the coordinates of the first letter in the word.  The student uses the 
coordinates to find the letter on the graph, and selects it using the mouse, keyboard or scanning.  
After a wrong answer, the student is corrected and prompted to try again.  After a correct answer, 
the letter is added to the word, and the student is prompted for the next letter.

The teacher controls the level of difficulty, how problems are presented, the words, letters and 
numbers used, the input method, and the amount of promping, correction and reinforcement.  
These options are all described in detail in the following pages.
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At the beginning of each level, or when the student is being corrected after several wrong 
attempts, the program helps the student by graphically demonstrating the current solution.

Move over to... 	 Move up to...

The program begins by circling the 0 position on the graph and saying “Start at zeo”.  The 
program then says “Move over to 2”, as in this example, and animates a line to the correct 
horizontal coordinate. The program then says “Move up to 2”, as in this example, and animates 
a line to the correct vertical coordinate.  These prompts vary, of course, relative to whatever axes 
are appropriate for the problem.

Level of Difficulty
The Graphic Speller has 9 levels of difficulty. To advance a level, choose “Advance a Level” 
from the Options menu, or type (Mac: ⌘-A or Win: Ctrl+A). To go back a level, choose “Back a 
Level” from the Options menu, or type (Mac: ⌘-B or Win: Ctrl+B).

You can go directly to any level by choosing “Go to Level...” from the Options menu, or by 
typing (Mac: ⌘-L or Win: Ctrl+L). A dialog something like this one will appear:

Enter the level which you would like to run, then click “OK”.

Following is a description of all difficulty levels.  Note that all levels 
can display graphs with up to 9 numbers on each positive or negative 
axis.  See Activity Settings for instructions on setting the graph size.
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Level 1

Level 1
A horizontal number line with positive numbers.

Level 2
A vertical number line with positive numbers.

Level 3

Level 3
A horizontal number line with both positive and negative numbers.

Level 4
A vertical number line with both positive and negative numbers.

Level 5

Level 5
A two-dimensional graph with positive numbers on each axis.

Level 6
A two-dimensional graph with a positive horizontal axis and a 
negative vertical axis.

Level 7
A two-dimensional graph with a negative horizontal axis and a positive vertical axis.

Level 8
A two-dimensional graph with negative numbers on each axis.

Level 9

Level 9
A two-dimensional graph with both positive and negative numbers 
on each axis.
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Activity Settings
To set the options for the problems being displayed, 
such as the words, letters and numbers being used, 
choose “Activity Settings...” from the Options menu, 
or type (Mac: ⌘-K or Win: Ctrl+K). A dialog 
something like this one will appear:

These settings apply across all levels.

The graph size can be set to any number from 4 to 9.  
This is the maximum number that will be displayed 
on each axis, as demonstrated below:

Graph xize 4 	 Graph size 9

Letters off

Use Letters
The “Use letters” checkbox causes the colored 
letters to be displayed on the graph.  Turn this 
feature off when you don’t want the student to 
guess at the spelling rather than to solve the 
problem by graphing.

Note:  The “Use letters” feature must be on to 
use the program by typing letters directly on the 
keyboard. When letters are off, keyboard users 
use the program by moving the cursor around 
the graph with the arrow keys, as shown in this 
example.
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Numbers off

Use Numbers
The “Use numbers” checkbox causes the numbers 
to be displayed on each axis of the graph.  You can 
turn off this option to have the student solve the 
problems by counting the positions on the graph.

For highly advanced students, you can turn off 
both the letters and the numbers for an even harder 
challenge.

Letter Options
The letter options allow you to specify how the letters are displayed on the graph.  The word 
length allows you to specify the length of the words used for each problem, from 1 to 9 letters. 
When the maximum word length is set to 1, each problem will consist of a single letter of the 
alphabet.  When the maximum word length is 2 or greater, each problem will be a random word 
within the specified length range, taken from a list of common English words.

When the lower case letters check box is off, the program displays upper case letters, regardless 
of the shift or caps lock keys.  When lower case is on, the program displays lower case letters.

Letters to lower left for negative axes 	 Letters to upper right

The “Always draw letters to the upper right” checkbox causes the letters to be displayed to 
the upper right of their graph position.  This setting provides consistency across all levels, but 
sometimes places the letters right over the graph numbers, as shown on the right, above.  When 
this option is off, letters will sometimes be placed down or left on the negative axis.  This is most 
useful when using large grid sizes and a high fill density, making the graph a little less cluttered, 
as on the left, above.
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Fill Density

Fill density 0% 	 Fill density 100%

The fill density is the amount of graph space that will be filled with random letters for distraction. 
At 0%, no extra letters beyond the letters in the word will be placed.

Animation Speed
The animation speed is the speed that the colored line moves across the screen when 
demonstrating the correct solution for the student, 5 being the fastest.  Set this to a low number 
for beginning students, so they can easily follow the animation, and set it to a high number for 
advanced students, so they don’t become bored.

Pause
The Graphic Speller normally uses speech and sound effects to prompt the student. To 
temporarily stop these audible prompts, choose “Pause” from the Activity Menu or type 
(Mac: ⌘-. or Win: Ctrl+.). The program will stop prompting until the user answers.  Use this 
option to give the student an unlimited time, or perhaps in a quiet classroom when you just want 
the program to be quiet!
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Input Options
The Graphic Speller provides several ways that 
a player can input their choices.  The simplest 
and fastest are direct selection with a mouse, 
touch screen or keyboard.  For players who 
cannot use the mouse or keyboard, scanning 
allows the user to input using one, two or three 
switches.

To change the input options, choose Input 
Options from the Options menu, or type (Mac: 
⌘-I or Win: Ctrl+I).  A dialog something like 
this one will appear:

Direct Selection
Mouse
Direct selection allows the user to directly clear or mark a square with a mouse, keyboard or 
other pointing device.  Direct selection with a mouse, touchscreen or similar device is the fastest 
for those players who can use it.  Simply click on the correct graph position to select it.

Letter Keys
Another direct selection option is to use the letter keys on the keyboard. The user simply types 
the letter at the specified coordinates.

Arrow keys move cursor

Arrow Keys
The arrow keys can also be used for direct 
selection is on.  Click the “Arrow keys” checkbox 
on, or turn off the “Use letters” option in the 
Activity Settings dialog. When the arrow keys are 
being used, a rectangle marks the current cursor 
position.  Use the arrow keys to move the rectangle 
up, down, right or left.  When the rectangle is at 
the position you want, press RETURN or ENTER 
to select it.
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Mouse dwell counter

Mouse Dwell
Mouse dwell is a feature for users who can use a 
pointing device, but cannot click. For example, a 
user may use a trackball or head tracking device 
to move the mouse pointer to the desired position.  
Once the pointer stops moving, the program will 
begin a countdown for the number of seconds 
specified in the “Auto-click mouse after” setting.  
If the mouse is not moved before the countdown 
is ended, the program will click the mouse for the 
user.

The “Tolerance” setting specifies the size of the 
target area, in pixels. The countdown continues as long as the pointer is within this target area. If 
the pointer is moved outside this area, the countdown is stopped.
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Scanning
In scanning mode, the computer will scan all possible answers for the student.  The student 
selects an answer by pressing one or more switches.

To change the scanning options, choose Scanning Options from the Options menu, or type (Mac: 
⌘-Y or Win: Ctrl+Y).  A dialog something like this one will appear:

Select the number of switches, type of scanning, and the scan rate (for timed scanning). The 
player can use one, two or three switches to control the program.

There are many different ways that The Graphic Speller can be set to scan. It may take some 
experimentation to determine the best method for each student.

With timed scanning (sometimes called “auto scanning”), the computer scans the available 
choices at the scan rate you have chosen.  With step scanning, the student uses two or more 
switches to scan the choices and make a selection.  The Graphic Speller offers several variations 
on each of these methods.

One Switch Scanning
When using a single switch for timed scanning, the computer will scan at the rate specified in the 
Scanning Options dialog.  The student uses the switch to select the current choice.  

One switch timed scanning is the most tedious of scan methods, and can be frustrating for a 
student who can handle more than one switch.  One switch scanning is best for students to young 
to understand two switch scanning, or those who are only capable of accessing a single switch.
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For one switch scanning, configure your switch interface to send a mouse click, space bar, 
RETURN character, number “1” or letter “Y” when the switch is pressed. The same keys on the 
keyboard can also be used as “switches”.

Two Switch Scanning
When using two switch scanning, the first switch selects the current item, just like with one 
switch scanning, and the second switch causes the program to scan. When the “Step scanning” 
box is checked, the student uses the two switches to step through and select a choice (the scan 
rate does not apply).  When “Step scanning” is off, the timed scanner acts like a third switch and 
causes the program to scan in reverse.

Two switch step scanning is the easiest way for switch users to use the program.

For two switch scanning, configure your switch interface to send a mouse click, RETURN 
character, number “1” or letter “Y” when switch #1 is pressed. Configure your switch interface to 
send a right-click, space bar, TAB character, number “2” or letter “N” when switch #2 is pressed. 
The same keys on the keyboard can also be used as “switches”.

Three Switch Scanning
With three switch scanning, the student uses an optional third switch to scan in reverse. As 
before, switch #2 scans to the next choice, and switch #1 selects the choice.  With three swtiches, 
the “Step scanning” option is always on (the scan rate does not apply).  

Thrree switch scanning is the fastest way for an accomplished switch user to use the program.

For three switch scanning, configure your switch interface to send a mouse click, RETURN 
character, number “1” or letter “Y” when switch #1 is pressed. Configure the interface to send a 
right-click, space character or number “2” or letter “N” when switch #2 is pressed. Configure the 
switch interface to send a TAB character or number “3” when switch #3 is pressed.

Letter scanning

Letter Scanning
When the “Sort by letter” button is on, the program 
scans through letters of the alphabet.  The student 
selects the correct letter to answer the current 
problem.  While a little harder to understand, the 
letter scanning method is the fastest way for the 
student to use the switches.



The Graphic Speller User’s Guide	 17

Row/column scanning

Row/column Scanning
When the “Sort by row/column button is on, the 
program first scans through all columns in the 
graph until the user selects the correct column.  
Then the program scans through all rows until the 
correct row is selected.

Sequential Scanning
When the “Sequential scanning” button is on, 
the program scans in a sequential pattern.  For 
example, in letter scanning, the program scans 
alphabetically.  In row/column scanning, it scans in 
ascending numerical order.

Random Scanning
When the “Random scanning” button is on, the program scans in a random pattern.  For example, 
in letter scanning, it might scan A-C-B.  In row/column scanning, it might scan the rows in order 
0, 4, 2.

Flashing Cursor
When the “Flashing cursor” button is on, the scanning cursor flashes once per second.  This 
makes it easier for the student to see the cursor, especially when using letter scanning.

Solid Cursor
When the “Solid cursor” button is on, the cursor doesn’t flash at all, but remains on the screen 
always.  There are two main reasons for using this option.  First, if the student is distracted by the 
flashing of the cursor, you can turn it solid.  Second, if the scan rate is set really fast, like 1 or 2 
seconds, it can sometimes be easier to follow with a solid cursor.
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Prompting and Reinforcement
The Graphic Speller provides many ways of prompting, reinforcing and rewarding the student.  
This section describes those features.

Speech
There are four levels of speech prompting and reinforcement in The Graphic Speller. To set the 
speech level, select “Speech” from the Options menu, then select the desired speech level.

Sassy Speech
Sassy speech provides all the prompting and reinforcing speech of verbose (described below), 
but does it in a much more playful way.  You might not like this for certain students, but for 
others it adds a dimension of fun.  There are even a few playful insults that your students will 
find amusing, at least.  Enjoy!

Verbose Speech
The default speech level is called “verbose”.  Verbose speech prompts the student for an answer, 
corrects mistakes and rewards correct answers.  When verbose speech is on, the student is 
prompted again if an extended period of time passes without a response or if a second attempt at 
a problem is needed.

Brief Speech
Brief speech is limited to the minimum prompting that the student needs to solve a problem.  
This option is useful when a student is using The Graphic Speller in a setting where too much 
speech may be distracting to other students.

Speech Off
When speech is off, audible tones are used to prompt, correct and reward the student.  These 
tones are consistent among all activities so their purpose is easily understood by the student.

Sound Effects
There are three levels of sound effect prompting and reinforcement in The Graphic Speller. 
To set the sound effect level, or to choose any of the other sound effect options, select “Sound 
Effects” from the Options menu, then select the desired sound effect level or option.

All Effects
When all effects are turned on, The Graphic Speller plays sounds to prompt, correct and reward 
the student.
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Limited Effects
When sound effects are limited, the program plays only the sound effects that are needed to 
prompt the student for a response, and to identify whether an answer is right or wrong.

Sound Effects Off
When sound effects are off, The Graphic Speller makes no sounds other than speech.

Click on Keypress
Selecting this option causes a slight “click” sound to be played whenever the student presses a 
key or switch.

Fanfare Sound
At the bottom of the Sound Effects menu is a list of sounds from which you can choose the 
sound that is played after a word is completed.  When you select a sound, it then becomes the 
“reward” sound for the next word.  Select “Random Fanfare” to have a random sound played 
after each word is solved.

Don’t Say ‘No’
When “Don’t say ‘No’” is checked on the Options menu, The Graphic Speller does not say the 
word “no” or play the “wrong” sound after a wrong answer.  Instead, the program just displays 
the answer as usual and prompts the student to try again.  

When the check mark is off, the program will say “no” or play the “wrong” sound depending on 
the current speech and sound effect levels.

To change the “Don’t say ‘No’” option, just select it from the Options menu to toggle it on or off.

Repeat Prompts Delay
You can specify the amount of time that The Graphic Speller waits for an answer before 
prompting the student again.  To do so, pull down the Options menu and select a delay from the 
“Repeat Prompts every” submenu.  The check mark indicates the current delay setting.  
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Reinforcement
The Graphic Speller can be made to display either a small rocket ship, a hot air balloon, 
or a kernel of popcorn in the lower right corner of the screen.  To turn on this option, pull 
down the Options menu and select the desired effect from the Reinforcement menu.

The launch pad shows the number of correct answers that are 
needed in order to reach the next level (see Rate of 
Advancement).  

As the student answers problems correctly, the launch pad counts 
down toward 0.  If a wrong answer is given, the countdown starts 
over.  

When the countdown reaches 0, the rocket or balloon takes off, 
or the popcorn pops.  The program then advances to the next 
level.

Colors and Background
You can choose the colors that The Graphic Speller uses for all screen elements. Use this feature 
when a student has difficulty seeing things on the screen, or as your fancy strikes you.  You can 
turn up the contrast or simply change the colors to something completely different.

To change colors, select “Colors and Background...” from the Options menu.  A dialog 
something like this one will appear:

Click on a color swatch to change that color.  A system color picker will come up with all the 
colors available on your system.
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Default colors 	 Text color changed

Text Color
The text color is the color of the graph lines, the numbers on the graph, and the prompt string 
(black by default).

Letter color changed 	 Dot color changed

Letter Color
The letter color is the color of all the letters in the graph, and the letters in the answer word (red 
by default).

Dot Color
The dot color is the color of the dots marking the location of a letter on the graph (yellow by 
default).
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Highlight color changed 	 Background color changed

Highlight Color
The highlight color is the color that is used for highlighting an object on the graph, such as the 
row/column cursor, and the opening animation on a level (green by default).

Use Solid Background/Background Color
By default, The Graphic Speller uses a cloudy sky background image.  You can turn that off 
by checking the “Use solid background” box.  The background will then be drawn with the 
background color (light blue by default).

White on black 	 Black on white

Black on White/White on Black
Clicking either of these two buttons changes all colors other than the highlight color to black or 
white on an opposite solid background.  For a custom high-contrast display, you can start with 
one of these, then fine tune the individual colors to suit.
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Program Control
The following sections describe some other options that control the way that The Graphic Speller 
functions.

Ignore Some Responses
In some cases, you may want the program to ignore certain responses from the student, and, of 
course, Marblesoft provides a way for you to do it!

To ignore some responses, use the Ignore submenu in the Options menu.  The three options are 
described here:

Ignore Wrong Responses
When this item is checked, the program will ignore all wrong answers.  Using this option, only 
correct answers will be acknowledged.

Ignore “Stray” Responses
The default behavior is for the program to ignore any responses outside the expected range.  For 
instance, when using the keyboard for direct selection, this option ignores any number keys.  
Likewise, the program would ignore mouse clicks that are not at a position that contains a letter..  
This option could be used for the student who is easily distracted by the computer’s negative 
responses or the student with limited motor control who has trouble physically pressing the right 
key or switch.

Ignore None
You can also have The Graphic Speller acknowledge all responses.  Typically, the word “No” or 
a sound effect is played after a wrong answer (see Prompting and Reinforcement - Don’t say 
‘No’), and the key that was pressed is shown on the screen.  The student is then prompted to try 
again.



24	 The Graphic Speller User’s Guide

Rate of Advancement
The Graphic Speller automatically sets the level of difficulty according to the student’s scores 
and the parameters set by the teacher.  There are three settings which determine when the 
program will advance or go back a level, and when the student is shown the correct answer.

To change one of these settings, choose 
“Rate of Advancement...” from the Options 
menu (Mac: ⌘-R or Win: Ctrl+R).  A dialog 
box like this one will appear:

Advance Rate
This is the rate at which the student will 
advance to a higher level.  If the student 
answers this many consecutive problems 
correct without an error, the program will automatically switch to the next higher level.

Backup Rate
The backup rate is how many wrong answers the program will accept before sending the student 
back to the next lowest level.

Show Answer After n Tries
This is the number of wrong answers that you want The Graphic Speller to accept before 
showing the student the correct answer.  When this number is reached, the student is shown the 
correct answer, then prompted to try again with the same problem.
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Tech Support
Contact Marblesoft Technical Support if you have problems installing or running The Graphic 
Speller.

Marblesoft Technical Support 
12301 Central Ave NE 
Suite 205 
Blaine, MN 55434

Phone
763-502-0440 

e-mail 
support@marblesoft.com.




